beaTunes v5 EA1 - Folder-based library won't sync properly anymore

Thilo's Avatar

Thilo

31 May, 2017 05:54 AM

I have a folder-based library to clean and preprocess audio files before importing them into iTunes. After processing I used to move these files into iTunes' auto-import folder. When switching back to beaTunes the library would be synced so that the previously moved files would be removed from the library.

Now with v5 this changed: files remain in the library and are marked 404 in the info screen.

Bug or feature?

  1. Support Staff 1 Posted by hendrik on 31 May, 2017 07:05 AM

    hendrik's Avatar

    Hey Thilo,

    the 404 basically means File not Found.

    Did you try to sync manually? Via File -> Synchronize?
    If not, please do and let me know what happens.

    Thanks,

    -hendrik

  2. 2 Posted by Thilo on 31 May, 2017 07:18 AM

    Thilo's Avatar

    I've synced manually now: nothing happens!

  3. Support Staff 3 Posted by hendrik on 31 May, 2017 07:36 AM

    hendrik's Avatar

    I have a folder-based library to clean and preprocess audio files before importing them into iTunes. After processing I used to move these files into iTunes' auto-import folder.

    What are the file system paths for your auto-import folder and your folder-based library?

    Also, can you please upload your logs (via Help -> Upload Logs)?

    Background info: I have completely rewritten the folder-based sync and one of the features is to be able to deal (to a certain degree) with moving files around. I.e. small changes to the filename do not automatically mean that beaTunes looses track of the file.

  4. 4 Posted by Thilo on 31 May, 2017 08:36 AM

    Thilo's Avatar

    My folder-based library lives in /Users/thilo/Music/beaTunes.

    In order to import files into iTunes I move them from above mentioned folder to /Users/thilo/Music/iTunes/iTunes Media/Automatically Add to iTunes.localized (using Finder).

    Log files have been uploaded.

  5. Support Staff 5 Posted by hendrik on 31 May, 2017 08:56 AM

    hendrik's Avatar

    Thanks for the logs.

    Strange. The log shows that the files have been removed from the internal database.

    What happens when you restart beaTunes?
    Do the files disappear?

  6. 6 Posted by Thilo on 31 May, 2017 10:18 AM

    Thilo's Avatar

    Restarting did not help. The following "File > Synchronize" either.

    Then I copied some new files to /Users/thilo/Music/beaTunes and - voila! - the old files were gone!

  7. Support Staff 7 Posted by hendrik on 01 Jun, 2017 07:20 AM

    hendrik's Avatar

    Odd. Is this behavior reproducible?

  8. Support Staff 8 Posted by hendrik on 01 Jun, 2017 02:00 PM

    hendrik's Avatar
  9. 9 Posted by Thilo on 01 Jun, 2017 03:56 PM

    Thilo's Avatar

    Yes, behaviour was reproducible with EA1. I'll test again with EA2 later today.

  10. Support Staff 10 Posted by hendrik on 01 Jun, 2017 04:39 PM

    hendrik's Avatar

    Cool. Thank you!

  11. 11 Posted by Thilo on 01 Jun, 2017 04:50 PM

    Thilo's Avatar

    I think I found something interesting:

    The problem only occurs when the library will become completely empty.

    Test case 1:

    • add 2 albums to the library folder
    • sync and edit files in beaTunes
    • move album 1 from beaTunes folder to iTunes folder so that 1 album stays in the beaTunes folder
    • switching to iTunes and back to beaTunes triggers syncing
    • album 1 has been removed from beaTunes which is the expected behaviour

    Test case 2:

    • (continued from test case 2)
    • move album 2 from beaTunes to iTunes folder (beaTunes folder is now empty!)
    • switching to iTunes and back to beaTunes triggers the automatic syncing
    • BUT: in this case album 2 is not removed from the beaTunes library! BUG!
  12. Support Staff 12 Posted by hendrik on 01 Jun, 2017 09:33 PM

    hendrik's Avatar

    I won't be able to look into this before Sunday.

    BUT this looks like a stellar bug report! I'll let you know, what I'll find.

  13. Support Staff 13 Posted by hendrik on 04 Jun, 2017 12:45 PM

    hendrik's Avatar

    Hey there,

    this should be fixed in the latest snapshot (same as the one for the genre setting issue you reported)

    Cheers,

    -hendrik

  14. 14 Posted by Thilo on 06 Jun, 2017 03:45 AM

    Thilo's Avatar

    Hi, I can confirm that EA3-SNAPSHOT fixed both of my issues. Thanks!

  15. Support Staff 15 Posted by hendrik on 06 Jun, 2017 06:18 AM

    hendrik's Avatar

    Awesome.
    Thanks for reporting!

  16. hendrik closed this discussion on 06 Jun, 2017 06:18 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac