MacOS Big Sur

Doug's Avatar

Doug

16 Jul, 2021 03:04 AM

Just want to make sure this works on Mac OS 11.2.3

Thanks all!

  1. Support Staff 1 Posted by hendrik on 16 Jul, 2021 06:50 AM

    hendrik's Avatar

    There shouldn’t be any problems. But please install the free trial and see for yourself, before you purchase!

    -hendrik

  2. 2 Posted by Doug on 16 Jul, 2021 06:05 PM

    Doug's Avatar

    Thank you for responding. Unfortunately my free trial expired before I upgraded to Catalina so can't check without purchasing.

    Doug

  3. Support Staff 3 Posted by hendrik on 16 Jul, 2021 06:30 PM

    hendrik's Avatar
  4. 4 Posted by Doug on 16 Jul, 2021 08:52 PM

    Doug's Avatar

    Just purchased, Beatunes analyzed my iTunes catalogue but won't sync. See warning screenshot attached. I am running Mac OS 11.2.3 and the latest version of Apple Music.

  5. Support Staff 5 Posted by hendrik on 17 Jul, 2021 04:10 PM

    hendrik's Avatar

    Hey Doug,

    macOS probably prompted you to allow beaTunes to communicate with Music. This dialog is unfortunately easy to miss and disappears after a while. More info can be found at https://blog.beatunes.com/search/label/AppleScript under the sub-heading AEpocalypse :: Averted.

    To fix the issue, please adjust the settings under System Preferences -> Security & Privacy -> Automation and make sure beaTunes is allowed to remote control Music.app.

    If this is not possible for some reason, I recommend to run

    tccutil reset AppleEvents
    

    from the Terminal.app command line, restart beaTunes and pay attention to system dialogs asking permission to control Music.app

    Hope this helps.

    -hendrik

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac