beatunes won't start after migration

iwerner's Avatar


10 Mar, 2010 09:22 PM

Dear Support,
I used BeaTunes 2 on a G4/933 on the latest version of Tiger and migrated via the Migration Assistant all my apps, documents etc. to a MacMini 2.53 with Snow Leopard 10.6.2.
Most of my apps work flawlessly, some had permission issues with updates which could be fixed by deleting and reinstalling the app.
As I started BeaTunes 2 now for the 1st time, it took quite a while and displayed an Schema Exception error.
I updated the app then and gave it another shot, which resulted in the same error.
Next step was to delete all logs and preference files I could find for BeaTunes.
Now the app is starting up, and closing again without further message what went wrong.
That so far for the "old" user.

Puzzling is, that under the new user who is also admin enabled, it works without issues.
I suspect that either a preference file is corrupt which is invisible for me or it is some issue depending on permissions.

Looking forward to hearing from you and many thanks in advance!

  1. 1 Posted by iwerner on 10 Mar, 2010 09:28 PM

    iwerner's Avatar

    thanks for you instant reply!
    I already reviewed the article you mentioned and the procedure didn't help
    it unfortunately.

    btw. latest iTunes, latest beaTunes, latest os x


    On 10.03.2010 22:22 Uhr, "beaTunes"
    <[email blocked]> wrote:

    > Hey iwerner,
    > thanks for your email. It's been added to the queue and I'll be taking a look
    > as soon as I can.
    > Usually, I try and respond to requests within 24 hours.
    > Based on your email, our helpdesk system believes you should check out the
    > following articles in our FAQ:
    > - "beaTunes does not start, shows JDBCException" at
    > bcexception
    > If this email is about a beaTunes bug, please make sure you let me know, which
    > versions of beaTunes and iTunes you are using. Also, please let me know, what
    > operating system version you are using.
    > I'll send an email to you (at [email blocked]) when I update your request.
    > Thank you!
    > tagtraum industries incorporated

    hunger...?? !

  2. Support Staff 2 Posted by hendrik on 10 Mar, 2010 09:40 PM

    hendrik's Avatar


    After you ran it as the admin-user, did you try the non-admin user


    Am 10.03.2010 um 22:28 schrieb iwerner <[email blocked]

  3. 3 Posted by iwerner on 10 Mar, 2010 09:50 PM

    iwerner's Avatar

    I did right now after seeing your @, but still no success.
    beaTunes starts and the window of the app can be seen for a fraction of a
    second and then the app is closing.
    should I send the new logs?

  4. Support Staff 4 Posted by hendrik on 11 Mar, 2010 10:07 AM

    hendrik's Avatar


    yes, can you please send me a fresh log (just the beaTunes.log should suffice).

    Also, can you please make sure that your ordinary user has write permissions for his home directory?



  5. 5 Posted by iwerner on 11 Mar, 2010 09:41 PM

    iwerner's Avatar

    hi Hendrik,

    think you pointed me to the needle in the hay ;-)
    it was the write permission in the home directory...duh!

    many thanks, I would have sought for ages for that...


  6. Support Staff 6 Posted by hendrik on 11 Mar, 2010 10:24 PM

    hendrik's Avatar

    Cool - so you got it working now?


  7. 7 Posted by iwerner on 11 Mar, 2010 10:39 PM

    iwerner's Avatar

    yup, it works just as intended, many thanks for your support, I appreciate

  8. hendrik closed this discussion on 11 Mar, 2010 11:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac