Failed to read audiofile

Jeanjan's Avatar


25 Jul, 2020 11:48 AM


I'm trying Beatunes.

The Library is folder based.

There's around 6000 tracks, only 4000 are showing up in beatunes.

This is what I found a lot in the logs :
2020-07-25 13:34:00,239 [205335] [ERROR][HibernateFileSystemLibraryLoader] com.tagtraum.audiokern.AudioMetaData: Failed to create AudioMetaData object: com.tagtraum.audiokern.AudioMetaDataException: Failed to read audiofile /xxx.m4a

I looked at the files permissions and stuff, I tried but couldn't find how to fix it.

When I switch the library to itunes based, the 6000 files are showing up.
The same files with the error message can be played and analyzed.

Any idea ?


  1. 1 Posted by Jeanjan on 25 Jul, 2020 11:59 AM

    Jeanjan's Avatar

    I'm using beatunes 5.2.10, itunes on MacOS X 10.14.6

  2. Support Staff 2 Posted by hendrik on 25 Jul, 2020 02:17 PM

    hendrik's Avatar

    Can you send the whole log file as an attachment, please?

  3. 3 Posted by Jeanjan on 27 Jul, 2020 05:42 AM

    Jeanjan's Avatar

    here it is.

  4. Support Staff 4 Posted by hendrik on 27 Jul, 2020 07:03 AM

    hendrik's Avatar

    Hey there,

    thanks for the logs.

    When using beaTunes for a folder-based library, all metadata (like id3 tags) is read using the library jaudiotagger. Apparently it believes your .m4a files are malformed and therefore cannot read them.

    When using beaTunes together with iTunes or, metadata is (in many cases) not read by beaTunes itself, but by iTunes/, which does not seem to have a problem with your files.

    Since jaudiotagger usually does not have an issue with .m4a files, there is at least something unusual about yours. To get to the bottom of this, I'd have to actually have one of these files for testing. Can you send one please?

    That all said, files don't get into this state on there own. Is there anything you did with them that could explain this? I.e. used some tagging software or so?

    Thank you,


  5. 5 Posted by Jeanjan on 27 Jul, 2020 07:37 AM

    Jeanjan's Avatar

    Here's a file

    I use DJ software like traktor, rekordbox, serato, virtualdj...
    also Itunes, mp3tag...
    And now beatunes.

    I'm organizing my collection so yes i tried and still trying software.

  6. Support Staff 6 Posted by hendrik on 27 Jul, 2020 05:09 PM

    hendrik's Avatar


    thanks for the file. It indeed appears to be malformed. I have checked with AtomicParsely. It reports

    APar_readX_noseek read failed, expect 8, got 1: end of file

    which basically means that the file ended prematurely. This kind of error may be ignored by some software packages and leads to errors with others.


  7. 7 Posted by Jeanjan on 27 Jul, 2020 07:15 PM

    Jeanjan's Avatar

    Thanks for the quick answer.

    Do you know any way to fix this?

    Thanks again.

  8. Support Staff 8 Posted by hendrik on 28 Jul, 2020 07:20 AM

    hendrik's Avatar


    I have implemented a workaround for this for Jaudiotagger (here). But it will take a while (at least a week or two, but that is no promise!) until it finds its way into beaTunes.

    If you're Python-savy, you might want to run mp4file --optimize (see mp4file) on your .m4a files. The file you sent to me was fixed by this (the extra byte at the end was removed).

    Hope this helps,


  9. 9 Posted by Jeanjan on 28 Jul, 2020 02:55 PM

    Jeanjan's Avatar

    I converted them in flac and they were instantly added to the Beatunes library.


  10. Support Staff 10 Posted by hendrik on 28 Jul, 2020 04:02 PM

    hendrik's Avatar

    That's another way of solving the issue! :-)

  11. hendrik closed this discussion on 28 Jul, 2020 04:02 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac