Music::Old Playlist from iTunes

gdunye's Avatar


25 Jan, 2020 08:11 PM

1. If you experienced a crash or other abnormal behavior, please attach the log file '' by dragging it from your desktop onto the 'Attach File' button below.

2. Please enter your message to us here.
Somehow old iTunes playlist (some not all), that I had in iTunes and removed within Music are still showing up and deleting them within beaTunes has no effect. I have checked all the other apps (TV, Podcast, Books) and these lists do not exist within those apps. I recently received a JV error when I tried to add a track to one of these phantom playlists.

* beaTunes: 5.2.5
* JVM: OpenJDK 64-Bit Server VM
* Version: 11.0.4-BellSoft+11
* Vendor: BellSoft
* OS: Mac OS X 10.15.2, x86_64
* Library:
* Memory: 92m - 640m
* Registered as: George Dunye

  1. Support Staff 1 Posted by hendrik on 27 Jan, 2020 11:25 AM

    hendrik's Avatar

    Hey George,

    Please shutdown both beaTunes and, then start beaTunes and synchronize again (File -> Synchronize). Perhaps it disappears then. Hopefully that fixes it.

    There have been reports that for some reason sometimes still reports old playlist as existing when in fact they have been deleted.

    Regarding that NullPointerException—that occurred when you tried to create a new playlist in a folder that does not exist. This is something that should not be possible, therefore the non-informative error message.



Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • 1.37 MB
  • Screen_Shot_2020-01-25_at_12.03.16_PM.png 350 KB
  • Screen_Shot_2020-01-25_at_12.07.14_PM.png 704 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac