"The RPC server is unavailable" when trying to synch.

Jack's Avatar


31 Jul, 2019 02:33 AM

Hello all. I get an error message when I try to synch BeaTunes with iTunes that "The RPC server is unavailable". Any advice?

  1. Support Staff 1 Posted by hendrik on 31 Jul, 2019 05:56 AM

    hendrik's Avatar

    Hey Jack,

    This usually means that for some reason beaTunes cannot talk to your Windows iTunes. Unless you are aware of some configuration that prevents this communication, the first thing I would try is re-installing iTunes so that you can be sure the iTunes automation server is correctly set up.



  2. 2 Posted by Jack on 31 Jul, 2019 06:14 PM

    Jack's Avatar

    Sounds scary. I have spent countless hours on iTunes tweaking my library. This is a disaster waiting to happen.

  3. Support Staff 3 Posted by hendrik on 01 Aug, 2019 06:38 AM

    hendrik's Avatar

    Yeah... I can understand not wanting to do this.

    Usually it's harmless though. All your edits should be stored in your files.
    In any case, it's always a good idea to back up your data (in this case the iTunes databases) before you do such a thing.

  4. Support Staff 4 Posted by hendrik on 01 Aug, 2019 06:40 AM

    hendrik's Avatar

    Method 1 from this site may also help. You might want to try that first!

  5. Support Staff 5 Posted by hendrik on 01 Aug, 2019 07:53 PM

    hendrik's Avatar

    Any luck?

  6. 6 Posted by Jack on 01 Aug, 2019 09:33 PM

    Jack's Avatar

    Oddly enough, I just tried the synch button one more time before I did something drastic, and it worked! It just worked. Weird! Thanks for your replies though; really appreciate the support!

  7. Support Staff 7 Posted by hendrik on 18 Aug, 2019 07:45 PM

    hendrik's Avatar

    You are very welcome.
    Glad it works now (though it is weird).

    I'm closing this discussion.



  8. hendrik closed this discussion on 18 Aug, 2019 07:45 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac