Analyze Song Dialog Does Not Appear in beaTunes 2

chortos's Avatar


14 Dec, 2009 09:22 PM

I have beaTunes 1.2.21 installed and I have used it in past to analyze many songs from my library. Today I installed the beaTunes 2.x trial and tried to analyze some songs with it, but for some reason, when I click Analyze Song/Playlist on the toolbar, choose Analyze Song/Playlist from the menu bar or from a context menu, press Ctrl+S (I have Windows XP Pro SP3) or drag-and-drop a song to the analysis queue in the side bar, nothing happens. beaTunes shows totally no reaction, and selecting the analysis queue in the side bar reveals that it is empty.

In beaTunes.log, this line appears:

<some integer> [DEBUG][AWT-EventQueue-0] com.tagtraum.beatunes.action.standard.AnalysisQueueAction: analyze songs

In system-error.log, this exception is logged:

Exception in thread "AWT-EventQueue-0" java.lang.AbstractMethodError
    at com.tagtraum.beatunes.analysis.AnalysisTasksDialog.<init>(SourceFile:109)
    at com.tagtraum.beatunes.action.standard.AnalysisQueueAction.analyze(SourceFile:175)
    at com.tagtraum.beatunes.action.standard.AnalysisQueueAction.actionPerformed(SourceFile:147)
    at javax.swing.AbstractButton.fireActionPerformed(
    at javax.swing.AbstractButton$Handler.actionPerformed(
    at javax.swing.DefaultButtonModel.fireActionPerformed(
    at javax.swing.DefaultButtonModel.setPressed(
    at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(
    at java.awt.AWTEventMulticaster.mouseReleased(
    at java.awt.Component.processMouseEvent(
    at javax.swing.JComponent.processMouseEvent(
    at java.awt.Component.processEvent(
    at java.awt.Container.processEvent(
    at java.awt.Component.dispatchEventImpl(
    at java.awt.Container.dispatchEventImpl(
    at java.awt.Component.dispatchEvent(
    at java.awt.LightweightDispatcher.retargetMouseEvent(
    at java.awt.LightweightDispatcher.processMouseEvent(
    at java.awt.LightweightDispatcher.dispatchEvent(
    at java.awt.Container.dispatchEventImpl(
    at java.awt.Window.dispatchEventImpl(
    at java.awt.Component.dispatchEvent(
    at java.awt.EventQueue.dispatchEvent(
    at java.awt.EventDispatchThread.pumpOneEventForFilters(
    at java.awt.EventDispatchThread.pumpEventsForFilter(
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(
    at java.awt.EventDispatchThread.pumpEvents(
    at java.awt.EventDispatchThread.pumpEvents(

My installation of beaTunes 1.2.21 still works.

  1. 1 Posted by chortos on 14 Dec, 2009 09:27 PM

    chortos's Avatar

    I forgot to add that I am using iTunes and that I have tried beaTunes 2.0.19 with and without bundled JRE, as well as 2.0.18 without the JRE and 2.0.10 with the JRE, both of which I found through Google.

  2. Support Staff 2 Posted by hendrik on 14 Dec, 2009 10:28 PM

    hendrik's Avatar


    Thanks for your mail.

    This sounds like you may have an outdated plugin installed. Any chance
    you ever installed the syncstep plugin?If so, removing that plugin
    probably solves the issue... Does it?



    Am 14.12.2009 um 22:27 schrieb chortos <[email blocked]

  3. 3 Posted by chortos on 15 Dec, 2009 03:28 PM

    chortos's Avatar

    Indeed, I had the SynchStep plugin. I did not find another way to remove it, so I just deleted the jar file from .beaTunes/plugins. The dialog now works. (And I have stopped using it a long time ago anyway.) Thank you!

  4. Support Staff 4 Posted by hendrik on 15 Dec, 2009 06:57 PM

    hendrik's Avatar


    I'm glad to hear that was it.
    And: Removing it that way is the only way to remove it.


  5. hendrik closed this discussion on 15 Dec, 2009 06:57 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac