working with playlist in beatunes, sorting, removing, moving songs.

james hubbell's Avatar

james hubbell

31 Dec, 2018 06:11 PM

1. If you experienced a crash or other abnormal behavior, please attach the log file '' by dragging it from your desktop onto the 'Attach File' button below.

I have used beatunes almost since your first release.

We have communicated in the recent past. My beatunes is not playing nice with itunes.

When I open beatunes it says I don’t have file sharing checked in itunes preferences. I do.
Then when I try to form playlists in beatunes it either says my itunes com module is installed incorrectly or it can’t find the itunes playlist.
One of my problems is I have about four folders of itunes stuff and a few more beatunes folders.

I decided over the holidays to seek help.

First, I called itunes tech services and had them take over my computer. They worked over 4 hours over two days to organize my itunes folders and consolidate everything onto one drive. At the end of all this I still couldn’t get beatunes to communicate with itunes

To say I am frustrated would be an understatement
Next, I decided to perform a radical surgery.
I copied every file in the itunes folder to a flash drive then deleted itunes and uninstalled it.

Then I did the same thing with beatunes.

Then I started from zero with itunes and installed it. Then followed with beatunes.

In both cases when I reinstalled both software packages they seemed to know I had the products installed in the past because it did not ask for my password or product authorization. For example (the code used to open up beatunes when you pay)

The result is the same. Could MacAfee be the culprit? I have had it installed all along with no problems.

Would be great if I had a list of all the files required for beatunes and what files it uses for itunes.

2. Please enter your message to us here.

* beaTunes: 5.1.11
* JVM: Java HotSpot(TM) 64-Bit Server VM
* Version: 25.181-b13
* Vendor: Oracle Corporation
* OS: Windows 10 10.0, amd64
* Library: iTunes
* Memory: 92m - 3072m
* Registered as: james hubbell

  1. Support Staff 1 Posted by hendrik on 02 Jan, 2019 07:56 PM

    hendrik's Avatar

    Just for my reference, here's the discussion we've had before.

    Hey James,

    that sounds like an incredibly frustrating and laborious process.

    I took a look at your logs and the problem still seems to be the same: beaTunes cannot communicate with your iTunes COM service.

    For some reason it is either:

    1. not installed correctly
    2. not the right version
    3. or beaTunes is not permitted to access it
    4. something else

    ad 1.: Usually this kind of issue can be solved by re-installing iTunes and then restarting the computer. I believe you have done this, so it apparently does not help.

    ad 2.: There is a 32 and a 64 bit version of both iTunes and beaTunes. This should match. I.e. if you are running 32 bit iTunes you must run 64 bit beaTunes.

    ad 3.: On Windows 10 there are sometimes permission issues. I.e. the operating system does not allow beaTunes to talk to iTunes. It is always better after a computer start to first launch beaTunes and let it start iTunes. If iTunes is not started by beaTunes, shut down beaTunes and try to start beaTunes as Administrator. This is not something you should usually do, but I wonder whether it does the trick.

    ad 4.: I have no idea what MacAfee does or does not do. Sure, it could be the culprit, but I have nothing that points in its direction. Perhaps it has activity logs you could inspect?

    Sorry to not be of more help.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac