UnsupportedAudioFileException: file is not a supported file type

jussi.kenkkila's Avatar


19 Jun, 2018 04:50 PM

I'm getting the "UnsupportedAudioFileException: file is not a supported file type" error on mp3 files. I'm using BeaTunes 4 4.5.7 on Windows 10 Pro N version 1803. I tried installing the Media Feature Pack, but it didn't help.

  1. Support Staff 1 Posted by hendrik on 19 Jun, 2018 08:12 PM

    hendrik's Avatar

    Hey Jussi,

    Could you please upload your logs via Help -> Upload Logs (from inside the app). Also, do you use the Flac file format at all?



  2. 2 Posted by jussi.kenkkila on 01 Jul, 2018 02:06 PM

    jussi.kenkkila's Avatar

    I uploaded the logs today. I don't use the Flac format.

  3. Support Staff 3 Posted by hendrik on 01 Jul, 2018 05:56 PM

    hendrik's Avatar

    Hey Jussi,

    Please update (for free) to version 4.6.18 available from https://www.beatunes.com/en/beatunes-download-old.html

    Using 4.6.18, does the problem persist?



  4. 4 Posted by jussi.kenkkila on 06 Jul, 2018 04:40 PM

    jussi.kenkkila's Avatar


    Updating both BeaTunes and the Media Feature Pack solved the problem. I think I may have had the old version of the Media Feature Pack (for build 1511), matching it to the Windows version (build 1803) was the key. I think the problem may have been started by the Windows update, which should have been followed by the Media Feature Pack update. As I have the N version of Windows that lacks those media features natively, they most likely are not updated automatically.

  5. Support Staff 5 Posted by hendrik on 07 Jul, 2018 05:11 AM

    hendrik's Avatar

    That probably explains it!


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac