Having trouble with Committing Changes

jjasonham's Avatar


06 Sep, 2010 07:39 AM

Everytime I commit to all changes, the status bar comes up, but never shows any progress. I always have to force quit. I've attached logs.

Thanks in advance,

  1. Support Staff 1 Posted by hendrik on 06 Sep, 2010 08:18 AM

    hendrik's Avatar

    Hi Jason,

    do you have any iTunes dialogs open while committing your changes? E.g. the song Get Info dialog (or any other dialog). If so, please close that dialog before committing any changes, as beaTunes cannot communicate with iTunes over AppleScript while any dialogs are opened. This would explain the issue you are experiencing.

    Please let me know, if that does not solve it!



    PS: I'm on vacation until Friday - please understand that I won't be able to react as swiftly as usually. Thanks.

  2. 2 Posted by jjasonham on 06 Sep, 2010 08:06 PM

    jjasonham's Avatar

    There weren't any open. I tried again to double check. Enjoy your vacation!

  3. Support Staff 3 Posted by hendrik on 12 Sep, 2010 01:05 PM

    hendrik's Avatar

    How long do you wait until you force quit?

    Can you please open the Console.app (in Utilities) and use it to look at the beaTunes logs while committing your changes. The latest log file is always named ~/Library/Logs/beaTunes/beaTunes.log Does it still show new entries while the progress bar might not move (yet)?


  4. 4 Posted by jjasonham on 13 Sep, 2010 02:39 AM

    jjasonham's Avatar

    I don't know what happened, but it seemed to go through this time! I
    was watching on Console and it completed. I completely closed iTunes.
    I think I may have force quit it last time and it didn't fully close
    (it does that sometimes when I use an app called TuneUp). Do I have to
    always have iTunes closed to commit changes?


  5. Support Staff 5 Posted by hendrik on 13 Sep, 2010 06:09 AM

    hendrik's Avatar

    That is odd - you actually need iTunes to be open, when doing anything with beaTunes.


  6. 6 Posted by jjasonham on 13 Sep, 2010 06:15 AM

    jjasonham's Avatar

    It opens back up automatically, anyway. Maybe the fact that it was
    frozen and not completely closed was the reason why I couldn't commit
    changes before. I've been doing them pretty consistently over the past
    couple of hours.

    Thanks so much for your support,

  7. 7 Posted by jjasonham on 13 Sep, 2010 06:24 AM

    jjasonham's Avatar

    The same thing is happening right as I type this.

    2010-09-13 01:52:26,539 [373572951] [DEBUG][AWT-EventQueue-0]
    com.tagtraum.beatunes.inspection.AlbumArtistTypoInspector: Song list:
    [Song@-512818221[name='Ego (Instrumental)',album='Studio Quality
    Instrumentals Pack 14',artist='Beyonce',genre='Instrumental'],
    Song@735609864[name='Halo',album='I Am...Sasha
    2010-09-13 01:52:27,466 [373573878] [DEBUG][AWT-EventQueue-0]
    com.tagtraum.beatunes.inspection.InspectionDialog: nextSibling : null
    2010-09-13 01:52:27,466 [373573878] [DEBUG][AWT-EventQueue-0]
    com.tagtraum.beatunes.inspection.InspectionDialog: nextNode :
    com.tagtraum.beatunes.inspection.AlbumTypoInspector Misspelled album
    2010-09-13 01:52:27,467 [373573879] [DEBUG][AWT-EventQueue-0]
    com.tagtraum.beatunes.inspection.InspectionDialog: previousNode:
    com.tagtraum.beatunes.inspection.AlbumArtistTypoInspector Misspelled
    album artist name
    2010-09-13 01:52:27,467 [373573879] [DEBUG][AWT-EventQueue-0]
    com.tagtraum.beatunes.inspection.InspectionDialog: nextSelectedNode:
    2010-09-13 01:52:27,467 [373573879] [DEBUG][AWT-EventQueue-0]
    com.tagtraum.beatunes.inspection.InspectionDialog: Issues left: 605
    2010-09-13 01:52:39,077 [373585489] [DEBUG][AWT-EventQueue-0]
    com.tagtraum.beatunes.inspection.InspectionDialog: Committing
    2010-09-13 01:52:39,082 [373585494] [DEBUG][AWT-EventQueue-0]
    com.tagtraum.beatunes.inspection.CommitChangesProgress: Max progress
    value: 1800
    2010-09-13 01:52:39,082 [373585494] [DEBUG][AWT-EventQueue-0]
    com.tagtraum.beatunes.inspection.CommitChangesProgress: Setting
    message label to: Ignoring only one artist
    2010-09-13 01:52:39,087 [373585499] [DEBUG][TunesUtilities]
    com.tagtraum.core.XmlDB: Storing list to
    2010-09-13 01:52:39,092 [373585504] [DEBUG][TunesUtilities]
    com.tagtraum.core.XmlDB: Storing list... Done.
    2010-09-13 01:52:39,092 [373585504] [DEBUG][TunesUtilities]
    com.tagtraum.beatunes.inspection.CommitChangesProgress: Index: 0,
    Progress: 1.0
    2010-09-13 01:52:39,092 [373585504] [DEBUG][TunesUtilities]
    com.tagtraum.beatunes.inspection.CommitChangesProgress: Progressbar
    value: 100
    2010-09-13 01:52:39,092 [373585504] [DEBUG][TunesUtilities]
    com.tagtraum.beatunes.inspection.CommitChangesProgress: ===== solution
    index: 0 =====
    2010-09-13 01:52:39,097 [373585509] [DEBUG][TunesUtilities]
    com.tagtraum.tunes.TunesUtilities: Get Track... with
    TrackFinder[song=Song@-1964763677[name='Linus And Lucy',album='A
    Charlie Brown Christmas',artist='Vince Guaraldi Trio',genre='Cool
    Jazz'], searchString=Linus And Lucy A Charlie Brown Christmas Vince
    Guaraldi Trio Cool Jazz,id=-6124896652326343919]
    2010-09-13 01:52:39,097 [373585509] [DEBUG][TunesUtilities]
    com.tagtraum.tunes.TunesUtilities: TrackCache miss. Hit percentage:
    2010-09-13 01:52:39,097 [373585509] [DEBUG][TunesUtilities]
    com.tagtraum.japlscript.ScriptExecutor: Script: tell application
    return tracks of item 1 of library playlists of (first source where
    kind is library) where persistent ID is "2AFFFEF2201BEB11"
    end tell

    2010-09-13 01:52:39,130 [373585542] [DEBUG][AWT-EventQueue-0]
    com.tagtraum.beatunes.inspection.CommitChangesProgress: Setting
    message label to: Changing album artist to Vince Guaraldi Trio

    This is the end of the last log. It's been here for a while. I'll let
    it keep running and update you.

  8. Support Staff 8 Posted by hendrik on 13 Sep, 2010 06:38 AM

    hendrik's Avatar

    At this point, how is iTunes doing? Any dialogs open? Using a lot of CPU?


  9. 9 Posted by jjasonham on 13 Sep, 2010 03:06 PM

    jjasonham's Avatar

    iTunes is just fine. No dialogs open. Not using a lot of CPU. It's
    iTunes 10, by the way. It's been on the same place since I emailed you

  10. Support Staff 10 Posted by hendrik on 13 Sep, 2010 03:14 PM

    hendrik's Avatar

    Hm.. I'm have an idea where this could come from..
    Could you please open the Terminal.app and type in:


    It should display a list like this:

    Macintosh-7:~ hendrik$ jps
    14229 Jps

    Make note of the number without the Jps and type:

    jstack NUMBER

    where you replace NUMBER with the number from Jps (in this example 14215).
    This should dump a threaddump to the output. Please copy that output and paste it into a message to me.



  11. 11 Posted by jjasonham on 13 Sep, 2010 03:21 PM

    jjasonham's Avatar

    This is the entire thing.

    Last login: Wed Sep 8 18:04:41 on console
    Jason-Hamlins-MacBook-Pro:~ jjasonham$ jps
    10042 Jps
    Jason-Hamlins-MacBook-Pro:~ jjasonham$ jstack 10042
    10042: No such process
    Jason-Hamlins-MacBook-Pro:~ jjasonham$

  12. Support Staff 12 Posted by hendrik on 13 Sep, 2010 04:31 PM

    hendrik's Avatar

    Really? While beaTunes was running? That's weird.

  13. 13 Posted by jjasonham on 13 Sep, 2010 05:34 PM

    jjasonham's Avatar

    Yes. I was still in the process of committing too.


    -----Original Message-----
    From: hendrik <[email blocked]>
    Sent: September 13, 2010 12:33 PM
    To: [email blocked] <[email blocked]>
    Subject: Re: Having trouble with Committing Changes [Problems]

  14. Support Staff 14 Posted by hendrik on 13 Sep, 2010 07:42 PM

    hendrik's Avatar

    Can you please try out:


    It's a dev snapshot that may fix the issue..



  15. 15 Posted by jjasonham on 15 Sep, 2010 03:29 AM

    jjasonham's Avatar

    I finally had a chance to install this. So far it's been working every
    single time! I'll let you know if it anything changes.

    Thanks so much!


  16. Support Staff 16 Posted by hendrik on 15 Sep, 2010 06:53 AM

    hendrik's Avatar

    Well, thanks for letting me know.
    Let's hope this really solves it.


  17. 17 Posted by BKC on 10 Dec, 2010 07:31 AM

    BKC's Avatar

    FYI, I had the exact same problem as jjasonham, above, and the same solution also worked for me.

  18. 18 Posted by David petree on 31 Dec, 2010 06:18 AM

    David petree's Avatar

    I have the exact same problem. I will install that update and see if it works for me too

  19. 19 Posted by David Petree on 31 Dec, 2010 06:36 AM

    David Petree's Avatar

    OK, that other version didn't work for me. It still hangs, but i got it to work if i do smaller changes. So, i guess it has something to do with the amount of changes. If i change 1, then commit the changes, it works, i even can do 2 at a time. I was trying to do about 10-15 , then commit those changes, but when i do that, it just locks up and doesn't do anything.

    and no, there is nothing open, like another window or something

  20. Support Staff 20 Posted by hendrik on 31 Dec, 2010 03:08 PM

    hendrik's Avatar

    Please do not use snapshots with version numbers lower than the current release (which is the case here).
    @David: Please start a new discussion and attach your logs to it (captured after you encountered that problem) - I'd love to look into it.



  21. hendrik closed this discussion on 31 Dec, 2010 03:08 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac