beaTunes was unable to determine the PUID of track 'Track 03'. This may indicate a network problem.

Colin Smart's Avatar

Colin Smart

31 Aug, 2010 10:15 AM

I am getting this error on all the songs I send for analysis.
I am running Mcafee Total protection firewall.
I have checked that it is giving benpuid full access to internet ( ie both ways)
I have reset firewall to ask before it denies access, and reinstalled Beatunes... but I get same message.
I have a firewall on the router as well ... but can't see what I need to set to let Batunes thro
What settings are needed to make the network access work?
Are there specific ports or services that need to be on?

Thank you in advance for your help.

if you experienced a crash or other abnormal behavior, you might want to attach log files from C:\Users\Colin\AppData\Local\tagtraum industries\beaTunes\logs

  • beaTunes: 2.1.12
  • JVM: Java HotSpot(TM) Server VM
  • Version: 16.3-b01
  • Vendor: Sun Microsystems Inc.
  • OS: Windows Vista 6.0, x86
  • Registered as: Colin Smart
  1. Support Staff 1 Posted by hendrik on 31 Aug, 2010 11:08 AM

    hendrik's Avatar

    Hi Colin,

    it should be sufficient to allow outgoing traffic to port 80 for the domain You definitely don't need to accept incoming connections.

    To verify what the issue may be, I'd disable the Mcafee firewall (but stay behind the router!), try beaTunes and see whether it works now. If that solves the issue, you at least know, which software you need to reconfigure. How exactly to configure it, you will have to ask the Mcafee people.

    Hope this helps,


  2. 2 Posted by Colin Smart on 31 Aug, 2010 11:19 AM

    Colin Smart's Avatar

    I have tried switching off Mcafee... no change

    With it on I have tried getting the colour and bpm for songs and that works .. using online resources .. so not sure what I am doing wrong.
    The log is empty

    It looks like it isn't mcafee.
    I will check the router

    Any other ideas?


  3. Support Staff 3 Posted by hendrik on 31 Aug, 2010 11:25 AM

    hendrik's Avatar

    To get color and bpm through online resources you have to allow connections from beaTunes itself to Those data is not provided by musicip/musicdns/amplifind or through genpuid. In other words, it's a completely different mechanism. It also never leads to the PUID message you saw.

    That said - the server for getting color/bpm from online sources it currently not operational anyway, so (right now) you wouldn't gain anything from using online resources for key/bpm/color.


  4. 4 Posted by Colin Smart on 31 Aug, 2010 11:38 AM

    Colin Smart's Avatar

    I was trying to check if it was just an issue with GenPuid, ( ie was I communicating ok from other modules of Beatunes) or a larger Beatunes / me issue.

    So I have done the following:

    1) Disabled Mcafee firewall ... No effect
    2) Reinstalled Beatune s ... No effect
    3) Checked Router ... no blocks on any items
    4) checked for any reference to Music DNS.Org or its IP address in Router or firewall

    Should I get a reply from a Ping to (
    I tried this and got timeout.

    Is there any other diagnostic I can try?


  5. Support Staff 5 Posted by hendrik on 31 Aug, 2010 12:04 PM

    hendrik's Avatar

    Hi Colin,

    So, I just checked and their server is up and running - meaning somewhere along the way something is going wrong.

    • do you have any problems with using online resources, i.e. traffic that does not go to musicip?
    • in other words, is this only a musicip issue?
    • the actual server name is - I do get ping replies from there. do you?
    • to make sure it's not something completely unrelated, could you please send me your logs? tells you where to find them.



Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac