Embedding beaTunes Information in the comments field of iTunes

cpwicks10934's Avatar

cpwicks10934

02 Oct, 2015 03:18 PM

When I perform the analysis of a song in beasTunes 4.5.3 it does not export the Key information into the comments field of my MAC based iTunes 12.3 the first time. I have to perform the analysis in beaTunes at least twice and some times three times in order to export the Key information.

This is new today. I did upgrade my MAC to ElCapitan yesterday and have only noticed this since upgrading. beTunes crashed and I had to rebuild the beaTunes databases this morning. Once rebuilt this need to perform analysis more than once has started to occur.

  1. Support Staff 1 Posted by hendrik on 02 Oct, 2015 07:55 PM

    hendrik's Avatar

    Hey Cliff,

    from just looking at the code I can not explain this behavior.
    Are you sure you can reproduce it with the new database?

    Cheers,

    -hendrik

  2. Support Staff 2 Posted by hendrik on 03 Oct, 2015 11:20 AM

    hendrik's Avatar

    Hey Cliff,

    the following you only write via email:

    When exporting the Key information from beaTunes to iTunes certain songs are populated as follows in the Comment field with this Key information

    C major (1d) :: nullKEY:C major (1d);

    It seems as though the Key information is being duplicated. Is there something in the Analysis preference selection that I should change to prevent this from happening?

    I believe the issue with the null is fixed in the current dev snapshot: https://www.beatunes.com/download/beaTunes-4-5-5-SNAPSHOT.dmg
    'Fixed' in this case does not mean that already existing null strings are removed, but that no new ones are added.

    Also, it seems to be that either the original comment was: KEY:C major (1d); or that you used both the keytocomment plugin and the new setting to write the key in front of whatever is in the comment. I can only recommend to use either the keytocomment plugin or that new setting (otherwise you end up with duplicate info). Or, if you don't have anything valuable in the comment anyway, choose the overwrite comment option.

    Cheers,

    -hendrik

    PS: FYI, I'm going to be traveling for the next two weeks and may not answer as quickly as I usually try to.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac