Error when open in Osx 12.5

Mar J's Avatar

Mar J

12 Aug, 2022 10:20 AM

I haven't used beatunes for a while and I tried it a few days ago. An error occurs when I run the app. I tried on ver 5.2.28 / 5.1.14 / 5.0.6 but not working on all of them. Am I the only one having this problem?

(I attached a screen capture.)

  1. Support Staff 1 Posted by hendrik on 12 Aug, 2022 10:46 AM

    hendrik's Avatar

    Hm. I don't think this is related to macOS 12.5—it starts fine for me.

    Can you please start the Terminal app and enter

    /Applications/beaTunes5.app/Contents/MacOS/beaTunes5
    

    (assuming you have installed beaTunes5 in the standard location under Applications).

    What's the output in the Terminal window? Can you please copy and paste it to this discussion?

    Thanks,

    -hendrik

  2. 2 Posted by Mar J on 12 Aug, 2022 11:05 AM

    Mar J's Avatar

    Come out like this.

    sup@Sup-iMac ~ % /Applications/beaTunes5.app/Contents/MacOS/beaTunes5
    2022-08-12 20:01:12,811 [ 48] [ERROR][main] com.tagtraum.beatunes.BeaTunes: java.nio.file.FileAlreadyExistsException: /Users/sup/Library/Application Support/beaTunes
    java.nio.file.FileAlreadyExistsException: /Users/sup/Library/Application Support/beaTunes
    at java.base/sun.nio.fs.UnixException.translateToIOException(UnixException.java:94)
    at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:111)
    at java.base/sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:116)
    at java.base/sun.nio.fs.UnixFileSystemProvider.createDirectory(UnixFileSystemProvider.java:389)
    at java.base/java.nio.file.Files.createDirectory(Files.java:690)
    at java.base/java.nio.file.Files.createAndCheckIsDirectory(Files.java:797)
    at java.base/java.nio.file.Files.createDirectories(Files.java:743)
    at com.tagtraum.beatunes.OSXBeaTunesProperties.findBeaTunesDirectory(SourceFile:38)
    at com.tagtraum.beatunes.BeaTunesProperties.<init>(SourceFile:54)
    at com.tagtraum.beatunes.OSXBeaTunesProperties.<init>(SourceFile:25)
    at com.tagtraum.beatunes.BeaTunesProperties.getInstance(SourceFile:83)
    at com.tagtraum.beatunes.BeaTunes.<clinit>(SourceFile:147)
    Exception in thread "main" java.lang.ExceptionInInitializerError
    Caused by: java.lang.NullPointerException
    at com.tagtraum.beatunes.BeaTunes.getRName(SourceFile:1408)
    at com.tagtraum.beatunes.Environment.a(SourceFile:85)
    at com.tagtraum.beatunes.Environment.get(SourceFile:45)
    at com.tagtraum.beatunes.BeaTunes.<clinit>(SourceFile:163)
    sup@Sup-iMac ~ %

  3. Support Staff 3 Posted by hendrik on 12 Aug, 2022 11:16 AM

    hendrik's Avatar

    It seems that beaTunes attempts to create the folder /Users/sup/Library/Application Support/beaTunes, but it already exists. This is weird, because it only attempts to create after checking that it does not exist.

    Is there anything out of the ordinary with your file system?

  4. 4 Posted by Mar J on 12 Aug, 2022 11:39 AM

    Mar J's Avatar

    I deleted that folder and it works fine. Thank you!

  5. hendrik closed this discussion on 14 Aug, 2022 10:54 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac