Can't load or sync music.app library anymore

Valentin's Avatar

Valentin

18 Dec, 2021 03:53 PM

Hi,

I'm using Beatunes for quite a long time now on Mac, and never experienced any problems with it until now.

However, since about a month, I can't sync my music.app library.

You'll find two screenshot :
- my mac os config,
- the error screenshot, when I try to add a new library based on music.app

Here's what I already tried :
- clean install of Beatunes (after removing everything related to Beatunes)
- creating a new Music library (Beatunes still doesn't recognize the new library)
- move my music library files to other places.

Using another user session on the mac seems to work : in a guest session, Beatunes finds the music library.

Thanks for your help :)

  1. Support Staff 1 Posted by hendrik on 19 Dec, 2021 01:08 PM

    hendrik's Avatar

    Hi Valentin,

    can you please reproduce the issue and then upload your logs via Help -> Upload Logs from within the beaTunes app?

    Thanks!

    -hendrik

  2. 2 Posted by Valentin on 19 Dec, 2021 03:52 PM

    Valentin's Avatar

    Hi,

    Yes, for sure.

    I did that just now (around Dec 19 - 04:48 PM)

  3. Support Staff 3 Posted by hendrik on 20 Dec, 2021 09:18 AM

    hendrik's Avatar

    Thanks, Valentin.

    For some reason it seems that AppleScript has stopped working under your main user.

    Can you launch the app Script Editor and execute the following little script:

    tell application "Music"
        return name
    end tell
    

    Does that work? Or do you get an error message?

    Did you install any other software that may have installed some AppleScript plugins or the like? E.g. in ~/Library/Scripts?

    Cheers,

    -hendrik

  4. 4 Posted by Valentin on 20 Dec, 2021 11:06 PM

    Valentin's Avatar

    It works great now.

    Actually, the Script Editor app didn't work (can't run script, and even can't save files)

    But it helped me find out that it seems I had an issue with the main apple script management after installing node.js
    When trying to run a script from Terminal, the output was "osascript: can't open default scripting component"

    Beatunes works correctly again, thanks for your help :)

  5. Support Staff 5 Posted by hendrik on 21 Dec, 2021 08:02 AM

    hendrik's Avatar

    For future reference, how did you install node.js, how did it mess up AppleScript, and how did you fix it?

    Thank you!

  6. 6 Posted by Valentin on 28 Dec, 2021 09:46 PM

    Valentin's Avatar

    Maybe it can help other users if I say that for some reason, I had to reinstall an Audio Unit.

    I tried to understand, but to be honest, I really don't know shat is the link between Node, an Audio Unit and AppleScript. I found the Audio Unit help on the internet.
    I've seen some things about Node and Audio Unit on the internet, so if you're reading this because of some issues try writing -> osascript -e 'tell app "Finder" to display dialog "Hello, World!"' on the mac console. If it doesn't work, then AppleScript is broken.

  7. Support Staff 7 Posted by hendrik on 29 Dec, 2021 10:24 AM

    hendrik's Avatar

    Thank you.

  8. hendrik closed this discussion on 29 Dec, 2021 10:24 AM.

  9. hendrik re-opened this discussion on 16 May, 2022 12:07 PM

  10. Support Staff 8 Posted by hendrik on 16 May, 2022 12:07 PM

    hendrik's Avatar

    Hey Valentin,

    sorry to bother you, but can you recall the name of the audio unit you had to re-install?

    Thanks,

    -hendrik

  11. 9 Posted by alorapittab on 16 May, 2022 01:19 PM

    alorapittab's Avatar

    I'm facing the same problem, I tried also to install the node.js but nothing changed. Actually I tried to rebuild the database and got an error. I use Logic Pro and I have quite a lot of AU installed, I had no idea some of them could interfere with Beatunes so it would be great to know which one would cause the problem :)

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Capture_d’écran_2021-12-18_à_16.42.51.png 194 KB
  • Capture_d’écran_2021-12-18_à_16.46.35.png 190 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac