Minor annoyance: spacebar triggers playback everywhere

Dominic Portain's Avatar

Dominic Portain

07 Oct, 2019 08:17 AM

Hi guys,

When you input data in the "Get Info" screen, the music player interprets EVERY SINGLE spacebar as a signal to continue playing music. This has become annoying enough after ten hours of editing metadata that I'm writing this ticket.
Please disable the music/spacebar association while an input field is active. Thanks!

* beaTunes: 5.2.0
* JVM: OpenJDK 64-Bit Server VM
* Version: 11.0.4-BellSoft+10
* Vendor: BellSoft
* OS: Windows 10 10.0, amd64
* Library: iTunes
* Memory: 92m - 2012m
* Registered as: Dominic Portain

  1. Support Staff 1 Posted by hendrik on 07 Oct, 2019 12:05 PM

    hendrik's Avatar

    Hey Dominic,

    Thanks for your message.

    In the Get Info panel, there is a little checkbox in the lower left corner: Play current song. Is this checked or not?

    Thanks,

    -hendrik

  2. 2 Posted by dportain on 07 Oct, 2019 01:27 PM

    dportain's Avatar

    Hey Hendrik,

    Sorry, I can't find that checkbox. The lower left corner is completely
    empty in the Get Info panel (see screenshot).

    Best,
    Dominic

  3. Support Staff 3 Posted by hendrik on 07 Oct, 2019 01:28 PM

    hendrik's Avatar

    Ah.. it's only visible in the Get Info panel for a single item (where it makes sense).

    I assume you have noticed the behavior in the multi item version of that panel, right?

  4. 4 Posted by dportain on 07 Oct, 2019 01:36 PM

    dportain's Avatar

    Oh, I've never seen the single item panel before. The checkbox in that
    panel is not checked.
    I need to specify: the space bar ONLY triggers playback in the multi
    item info panel when the "Genre" input field is selected.

  5. Support Staff 5 Posted by hendrik on 07 Oct, 2019 09:20 PM

    hendrik's Avatar

    That narrowed it down. Looks like it's specific to Windows.

    I believe I have it fixed in the current dev snapshot https://www.beatunes.com/download/beaTunes-5-2-1-SNAPSHOT-x64.exe

    Thanks for making me aware if it!

    -hendrik

  6. Support Staff 6 Posted by hendrik on 09 Oct, 2019 02:26 PM

    hendrik's Avatar

    Hey Dominic,

    just wanted to check—did the snapshot solve the issue?

    Thanks,

    -hendrik

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac