Grouping not showing up correctly

Christian K.'s Avatar

Christian K.

24 Aug, 2017 09:52 PM

So I'm using the "grouping" tag to give additional details to the song. I can see the grouping in iTunes but in beaTunes it simply doesn't show up. I just did a rebuild db and still not working. I tried doing the refresh from file for files that I know that have the grouping saved into the id3 tag, but beatunes still not showing any changes.

Half of my library has additional information about the song on the grouping tag, but beatunes shows less than 200.
I'm using a folder based library.

Any ideas?

  1. Support Staff 1 Posted by hendrik on 25 Aug, 2017 05:10 AM

    hendrik's Avatar

    Hey Christian,

    I'm using a folder based library.

    If you are using iTunes, why are you using a folder-based library? Any particular reason?

    That said, grouping and iTunes have undergone some changes in the last couple of iTunes updates. Specifically, before version 12.5 iTunes used to store grouping in a regular ID3 tag called TIT1. The current version of iTunes does not do that anymore. Instead it stores grouping in the non-standard ID3 tag GRP1. This change has apparently been motivated by the introduction of the fields work and movement. iTunes 12.5 and later stores work in the ID3 field that used to be used for grouping (TIT1).

    So depending on when (depends on iTunes version) you added your grouping tags in iTunes, they may have either been written to TIT1 or GRP1. This means in beaTunes you may find some of those tags under work in a folder-based beaTunes library.

    You'd probably not see any of these issues, if you used an iTunes-based beaTunes collection.

    Cheers,

    -hendrik

    PS: Additional links:

  2. Support Staff 2 Posted by hendrik on 28 Aug, 2017 08:28 AM

    hendrik's Avatar

    Hey Christian,

    did this explanation solve the issue?

    Thanks,

    -hendrik

  3. 3 Posted by Christian Kopač on 28 Aug, 2017 11:53 AM

    Christian Kopač's Avatar

    Hi Hendrik,
    I’m using a folder based library as I use beets in combination with a
    custom folder structure. Gives me way more flexibility.
    I asked the Swinsian developers how is the app saving the tags and they
    told me that the grouping tag is saved in the TIT1 field.
    That being said, even when I refresh from file, the information is not
    shown on the work or grouping column.

  4. Support Staff 4 Posted by hendrik on 28 Aug, 2017 01:46 PM

    hendrik's Avatar

    Hey Christian,

    can you please send me a sample file? I'd like to reproduce the issue.

    Thanks,

    -hendrik

  5. 5 Posted by Christian Kopač on 28 Aug, 2017 03:56 PM

    Christian Kopač's Avatar

    Here’s an example:
    https://dl.dropboxusercontent.com/u/247177/01%20Coffy%20Is%20the%20Color.mp3

    This file should have “Radio” in the TIT1 field which is not showing up in BeaTunes.
    In Swinsian it shows correctly under the Grouping field, in iTunes it shows up under Work Name.

  6. Support Staff 6 Posted by hendrik on 29 Aug, 2017 01:44 PM

    hendrik's Avatar

    Hm..

    there maybe something in the code. Can you please try out the current dev snapshot https://www.beatunes.com/download/beaTunes-5-0-5-SNAPSHOT.dmg ?

    Does that work better for you?

    Thanks,

    -hendrik

  7. 7 Posted by Christian Kopač on 30 Aug, 2017 11:13 AM

    Christian Kopač's Avatar

    After a library refresh I think it is working now!
    Thanks Hendrik.
    btw can I ask how big the beaTunes company is? will you be hiring any extra
    people or is it a one man project?
    Best,

    Christian

  8. Support Staff 8 Posted by hendrik on 30 Aug, 2017 12:20 PM

    hendrik's Avatar

    btw can I ask how big the beaTunes company is? will you be hiring any extra people or is it a one man project?

    Sorry, but tagtraum is a one-man-show.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screen_Shot_2017-08-24_at_23.52.16.png 134 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac