BPM not working very well

jjamesge1's Avatar

jjamesge1

04 May, 2011 03:35 PM

I've tried to make matchlists using BPM in beatunes, and it does not work very well. I tried to make a list, out of my entire library (not even limiting the genre) by "BPM is no greater than 100", and I got a total of 15 songs, and only the original seed song was under 100, and the rest was over 100.

If I limit the genre to the same asseed song, Beatunes only spit out 4 songs.

I've tried to make BPM matchlists with a range of BPM (say, trying to limit to BPM betwen 80 and 120), and every time, it say's it can't make a matchlist.

I've got thousands of songs between 80 and 120 BPM.

Using BeaTunes2: v.2.1.19 windows

  1. Support Staff 1 Posted by hendrik on 04 May, 2011 04:53 PM

    hendrik's Avatar

    Hi,

    matchlists depend on the rules you configured - without knowing those, it's hard to tell what's going wrong. Can you describe the ruleset (not individual filters) you used?

    Thanks,

    -hendrik

  2. 2 Posted by jjamesge1 on 05 May, 2011 06:31 AM

    jjamesge1's Avatar

    When I used more than 1 track (I tried with I think 4 seed tracks), it
    worked. Not really sure why it did what it did when I only had a single seed
    song. That was rather odd. As far as the rules, I pretty much using the
    default values, then just trying to pick a single song, then a range of BPM.
    I used "no less than 80" and then "No greater than 120" for the original
    list I complained about. I did limit the list to genre "country" picking the
    "is" modifier.

    I tried a different track just now, and I did get 26 songs in the range 80
    to 120 BPM in the country genre, although I say make a 100 track list.
    Anyway, it looks like I need at least 3 seed songs to get 100. I tried 2
    seed songs and came up with a list of 83 tracks. Curious.

    -----Original Message-----
    From: hendrik
    Sent: Wednesday, May 04, 2011 11:55 AM
    To: [email blocked]
    Subject: Re: BPM not working very well [Problems]

  3. Support Staff 3 Posted by hendrik on 08 May, 2011 03:25 PM

    hendrik's Avatar

    Hi,

    it's really hard to tell without knowing what rules you used, what's going on. There are a bunch of different "default" rules, and they have different restricting influences.

    You can find out about the rules in the beaTunes preferences.

    -hendrik

  4. 4 Posted by jjamesge1 on 09 May, 2011 06:09 PM

    jjamesge1's Avatar

    I figured it out. I have to use more than a single song to get a list. Looks
    like 3 is the minimum for a 100 song matchlist, but using 1 seed per every
    20 songs is the sweet spot. Although more seeds helps if your trying to get
    less variations between songs.

    -----Original Message-----
    From: hendrik
    Sent: Wednesday, May 04, 2011 11:55 AM
    To: [email blocked]
    Subject: Re: BPM not working very well [Problems]

  5. Support Staff 5 Posted by hendrik on 11 May, 2011 06:48 AM

    hendrik's Avatar

    You might also want to change the the configured rules in the preferences.

    Anyhow - I will close this thread then.

    -hendrik

  6. hendrik closed this discussion on 11 May, 2011 06:48 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac