No subject

Terry Manning's Avatar

Terry Manning

07 Nov, 2010 01:44 PM

Beatunes 2.1.14 recently refused to start. (in OS 10.6.4) yielding following "serious" error message:
java.lang.incompatibleClassChangeError: Found interface.com.tagtraum.beatunes.library/iTunesMusicLibrary, but class was expected
Not sure, but problem seems to have started immediately after I installed latest Java update recommeded by Apple.
Please advise. Thanks

  1. Support Staff 1 Posted by hendrik on 07 Nov, 2010 01:50 PM

    hendrik's Avatar

    Hi Terry,

    Most likely this is due to some outdated beaTunes plugins.

    Please go to your plugin directory and update (don't delete, unless you know your task queue is empty) all plugins you have in there. Plugins are listed in http://blog.beatunes.com/search/label/Plugin and http://help.beatunes.com/faqs/plugins/how-to-install-a-plugin tells you where to find the beaTunes plugin folder.

    Hope this helps,

    -hendrik

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac